Welcome to the Titanfall 2 Forums. We have made a few adjustments to help eliminate spam and fake accounts. Starting today to participate in discussions, you must own Titanfall 2 and have a linked EA account. If you're having issues posting but do own the game, log out completely and clear your browser cache, cookies, and temp files, then restart the browser.

Disconnect//Main Menu After Every Match

2

Comments

  • The same for me on PS4....!!!
  • Same thing is happening to me.. on PC.. I have lag and then server timeout during multiplayer matches. I've tried changing data centers. My pings are good from 30-40ms. This has been happening all day for me.
  • steeldragonz
    12 postsPosts: 13
    takethatx2 wrote: »
    Same thing is happening to me.. on PC.. I have lag and then server timeout during multiplayer matches. I've tried changing data centers. My pings are good from 30-40ms. This has been happening all day for me.

    if you see my vid in the thread, its pretty much the same. Except i have never been dc during a match. Something up with the Origin//EA//Respawn Servers, because even after closing the game and Origin and restarting still get the same issue of reconnecting. And my data center ping is 13ms
  • I'm having the exact same issue. originally I had no problems as I was staying with family and played a good 26hrs with no issues at all. After going home yesterday and trying to play now I have this issues. Ive tried Wired connection on my Laptop and my Desktop and the exact same problem. I've also tried to open to ports from Titanfall 1 as I cant find Titanfalll 2 ports listed but still getting and issue. The only explanation I can think of is there is and issue with ISP. My Folks are on BT and I m on plusnet. I remember reading back when Titanfall 1 was released that there was an issue with PlusNet where this was similar where the game is so new it wasn't on their priority traffic list. Once it was added to their priority traffic list then there problems cleared up for most. What ISP are you all using plusnet or someone else?
  • steeldragonz
    12 postsPosts: 13
    Im on Zen Internet, but I never had this issue with Titanfall 1, only 2
  • eQuaZ0r
    9 postsPosts: 9
    edited November 2016
    Very similar issues here - first time I play I seem to get a good game, after that though when searching for the next I get disconnects/timeout and booted back to menu. Sometimes a freeze during the dropship screen, somtimes I get into match and everything is stil (including my crosshair) except I can move, checking score screen takes ages and when it pops up shows a ping of anywnere from 3000ms and upwards (highest I've seen is 6000+).

    Restarting game or PC makes no difference, seemingly after a while of trying (probably about 15-20minutes) I'll get back into a game and the whole process starts again.

    I've tried high/low graphic settings, closing running programs, reboots, changing network settings/priority as suggested for the other issues, changing datacentres (UK London is my default and shows 12ms). Changed windows firewall settings, etc etc etc

    Plenty of other online games have no issues, I.E BF1 currently playing, Titanfall 1 was/is fine.

    ISP is SSE Fibre Broadband - (Daisy Wholesale). Speedtest.net and speedof.me always show a low ping (sub 15ms) 68-70mb down, 18-20mb up. No other users on home network, no other problems with websites etc.

    PC Spec:
    Nvidia GTX970
    Intel i7 2600k
    24gb RAM
    2tb+ spare disk space
    Windows 10 Anniversary edition, latest graphic drivers and hardware drivers.

    I AM using wireless to connect to my router - but this works fine for everything else and I even use it to stream to steamlink on occasion (albeit not in this scenario).
    Router is a Technicolor TG589VAC if it helps - I actually also have a BT Home Hub 5 plugged into that for the transmission of wireless AC as it has better range, the wireless is disabled on the Technicolor. But to re-iterate again no issues anywhere else with connectivity so do not expect this to be the source of the problem.

    would love this solved as really can't enjoy multiplayer without it being fixed. I am wondering after previous threads if traffic management is an issue (would be interesting to find out if other users use a Daisy Wholesale provider).

    Or are the servers just a bit jammed up?

    I would post a video but others have done plenty already that cover my issue.

    Would be happy to submit any logs or run any console commands required etc - please get in touch.
  • BetaDaysUK
    11 postsPosts: 12
    I've contacted PlusNet (my ISP) to see if they can add the games "signature" to the companies traffic management platform. This appeared to fix a very similar problem that was experienced with Titanfall 1.
  • eQuaZ0r
    9 postsPosts: 9
    Hey BetaDaysUK - I've just sent a tech request to SSE in a similar vein (Daisy Wholesale) will see what they come back with and keep an eye on here as well - still unsure if its not a game issue or not.
  • Wilkostein
    4 postsPosts: 4
    It's definitely a game issue, no other game I play has these issues. The devs need to get their finger out and sort this ASAP or at least acknowledge there is a problem.
    PS i'm on PS4 and Plusnet.
  • I dont know about all but I got to play one so far seems it was fixed
  • gonna try again but Im getting excited
  • Ok 2 games in a row no problems looking good titanfall thank you I have no more complaints now its time to enjoy the game
  • Jacket785
    157 postsPosts: 162 ✭✭
    Ok 2 games in a row no problems looking good titanfall thank you I have no more complaints now its time to enjoy the game

    SSDD for me. Getting disconnected at the "Jumping at location" screen and any match that I join, I get disconnected in 3-5 minutes.
    "My expectations are usually low, so that I'm not disappointed"

  • steeldragonz
    12 postsPosts: 13
    Just had a game to test if anything had changed.... It hasnt. I was disconnected the moment the game ended and had to sit through all the reconnecting again.

    A response to this would be good, you are starting to lose creditibilty as a good CM
  • azprodigy
    31 postsPosts: 31
    This issue is being ignored. They answer to every other thread except this one. I'm still being kicked at the drop ship or 2 minutes into the game. Anyone know how to go about getting a refund if I purchased digitally on my Xbox?? Call Microsoft?
  • Having the same issue on ps4. Kicks to main screen with connection to server timed out error. Multi player is unplayable. In thinking of asking for a refund unless this gets settled soon.
  • Jacket785
    157 postsPosts: 162 ✭✭
    Even though it's listed in the "Known Issues" thread, I worry that they just won't bother fixing the issue due to how "minor" the issue is because only a "very few" people are experiencing this. Seriously, any response would really be nice. **** I would take "We're looking into the issue and we understand your frustration". I'm not going to bother contacting EA for this because this is a Respawn issue, not an EA issue (though it's possible).
    "My expectations are usually low, so that I'm not disappointed"

  • I would say if the game is unplayable to even a small percent of people who boughr it that is a big issue. The campaign is fairly short and if i cant play online this game has no value left.
  • pr0dijay1
    1 postsPosts: 1
    azprodigy wrote: »
    I click on a game mode...it finds a game...brings me to a black screen that says "Jumping to location". I hear the noise of the jump ship but still black screen. It then kicks me out saying "error to server timed out" Im on Xbox 1.

    Same here. I get that about 75 percent of the time. I love the game but won't take that much longer.
  • Same here! I have no issues at all when playing by myself. Unfortunately when my best friend and I make a party we will get one, maximum 2 games before I am disconnected. It will either drop me on the rewards screen, which if I am quick with rejoining multiplayer it will still show me. The worst part is after that if we try to launch a game my friend will get in fine and I will be disconnected. If I try to rejoin it will just put me into a completely separate game.

    Really frustrating. It should be seamless to make a party and play with friends, especially only one. Please please fix this. Love the game but this totally kills the enjoyment. The only other game we have had issues with playing together is battlefield 1 lol, but they seem to have fixed that.

    i7-6700k
    GeForce 1060 6GB
    16gb DDR4 Ram
    Windows 10
  • Popino
    1 postsPosts: 1
    Same here, don't even get to see post match screen. Match ends loading black screen and disconnect. Really this sucks, not playing the game right now because of that, since it takes forever to connect again after that error.
  • steeldragonz
    12 postsPosts: 13
    Well I tried twice again today and the same thing happened in both games, i was disconnected at the end of both games and thrown straight to the main again.

    Windows 10 Pro [whatever the most recent update is as of this post]
    Intel® Core™ i7-6900K Eight-Core[16 logical core] 3.20 GHz @ 4Ghz
    2x EVGA GeForce GTX 980 Ti SC GAMING ACX 2.0+
    64GB
    Creative Titanium Fatailty Championship w/ IO panel
    1x Samsung SM951 M.2 PCIe NVMe SSD 512GB
    2x 128GB OCZ SSD Raid0
    1x 1TB WD
    4x 1.5 TB WD HDD
  • Xer0Signal
    13 postsPosts: 14
    Jacket785 wrote: »
    I would take "We're looking into the issue and we understand your frustration". I'm not going to bother contacting EA for this because this is a Respawn issue, not an EA issue (though it's possible).

    Seriously. I can't believe they can't even chime in to say something like that. Poor community management.
  • steeldragonz
    12 postsPosts: 13
    edited November 2016
    So just now, i went to test if im still having the same issue [it was going to be the last time i bothered], but im now getting the start to a black screen problem.

    I will give this about 2-3 minutes to see if i can fix this, if i cant well im just writting this off as a lesson learned and that i will NEVER BOTHER WITH EA / ORIGIN / RESPAWN again.


    edit: fixed the black screen, played a game, got dc'd at the end... done.
  • Hello, I have the same issue, after every multiplayer match, I get disconnected from server. I tryed to open the port on the router, but nothing has changed. Why devs don't asnwer us about this problem?
  • Same here ... i'm getting one solid game a night and then its disconnected and I rarely get to even complete another until the next day. Driving me crazy!
  • They still can't be bothered to address us in the forum.
  • steeldragonz
    12 postsPosts: 13
    edited November 2016
    CM hasnt even been online in 2 days, let alone bothered to reply to us here in about 10-11 days, obviously they dont care now that they have our money.
  • Jacket785
    157 postsPosts: 162 ✭✭
    CM hasnt even been online in 2 days, let alone bothered to reply to us here in about 10-11 days, obviously they dont care now that they have our money.

    Look at the 2nd to last post in this thread. There has been an update, but that's about it.

    https://forums.titanfall.com/en-us/discussion/5547/error-connection-to-server-timed-out/p4
    "My expectations are usually low, so that I'm not disappointed"

  • Xer0Signal
    13 postsPosts: 14
    Gotta love how Respawn is active everywhere but their own forums. Oh well!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!