Welcome to the Titanfall 2 Forums. We have made a few adjustments to help eliminate spam and fake accounts. Starting today to participate in discussions, you must own Titanfall 2 and have a linked EA account. If you're having issues posting but do own the game, log out completely and clear your browser cache, cookies, and temp files, then restart the browser.

Opening Titanfall 2 keeps going into windowed mode.

mx200394
5 postsPosts: 6
It lately has been a ritual for me every time I open titanfall 2 through Origin that I have to go to settings>video> change windowed mode to full screen. Has this happened to anyone else? It gets quite annoying when I want to get on and play.

Comments

  • dredd01
    1 postsPosts: 1
    This. ^^

    And graphics option changing. Every time i must quit game than enter again. Also Nvidia Geforce Experience DSR turn out every time i'm quit the game.

    GTX 1070. W10. Drivers up to date.
  • AUSSIEPR0
    18 postsPosts: 20
    The 'windowed' mode issue is related to 'Origin in-game'. When I have that disabled I have no issues at all.

    (Unfortunately we need Origin 'in-game' to join/invite peeps)
    - COG_AUSSIEPRO
  • mx200394
    5 postsPosts: 6
    Indeed, and I never really used the Nvidia Geforce Experience because the biggest flaw to it is that it does not read your hardware as a whole so it adjusts games based on what graphics card you have. I am running a EVGA GTX 1070 Super Clock But there is not much that card cannot handle but when it comes to the hardware side I am sort of lacking using an AMD 6300 (Yes I know bottle necks it is only for the time being till I get a new CPU MoBo and Ram). I do not know why this issue though was not addressed in the first patch. I would like to know if anyone else other than us have this problem as well.
  • Darkzeta89
    16 postsPosts: 16
    This is yet another bug in the increasing list of annoyances in this game.

    I also have to change the V-synch options. I always use Nvidia Adaptive Vsynch but every time I start the game its like I have Vsych off (even though the menu says its on).
  • fenchu
    8 postsPosts: 17
    how the **** did these bugs get past testing , these are basic school rooms errors on a engine thats well over 5 years old and was used on previous titanfall.

    When are we going to get any word on dsr bug ?
  • thedarksleep
    10 postsPosts: 13
    Same issue for me, I have a 4K monitor. If I run the monitor on native resolution in desktop I cannot get TF2 to start in Full Screen, neither ALT + Enter does not help. This is extremely frustrating.

    The only way I could find a solution is to downscale the desktop resolution to 1920x1080 and then TF will run in Full Screen Mode.
    Video card: GTX 970 - Drivers up to date.


    **** is happening ?
  • well here is kind of a fix?
    http://imgur.com/a/tITsi
  • wwizzarrdry
    74 postsPosts: 78
    I only get the annoying windowed mode bug when I launch Titanfall from within Steam (as non-steam game).

    Perhaps an intentional bug introduced by EA to promote using their Origin launcher? Origin doesn't even support a Big Picture mode with controllers.
  • mx200394
    5 postsPosts: 6
    I only get the annoying windowed mode bug when I launch Titanfall from within Steam (as non-steam game).

    Perhaps an intentional bug introduced by EA to promote using their Origin launcher? Origin doesn't even support a Big Picture mode with controllers.

    I open titanfall 2 only using Origin or the Icon. This issue should be replaced my GTX 1070 has all the updates and I even turned of the Nvidia Gsync options to see if that would work. Still not.
  • mx200394 wrote: »
    Indeed, and I never really used the Nvidia Geforce Experience because the biggest flaw to it is that it does not read your hardware as a whole so it adjusts games based on what graphics card you have. I am running a EVGA GTX 1070 Super Clock But there is not much that card cannot handle but when it comes to the hardware side I am sort of lacking using an AMD 6300 (Yes I know bottle necks it is only for the time being till I get a new CPU MoBo and Ram). I do not know why this issue though was not addressed in the first patch. I would like to know if anyone else other than us have this problem as well.

    I think it does scale with your hardware actually. I run a i7 4790k and a 980ti setup but I was using a amd 8350 before and when I changed out my cpu for the i7 a lot of my games that suggested just high or even medium settings on some things in geforce experience immediately shot every setting on every game up to ultra. My only limiting factor initially was the weak amd cpu and all my cpu heavy games changed to max when I upgraded...there was no other hardware change on the gpu side so I think it does register it all. Also when you check your computer in geforce it displays gpu, cpu and ram. If it collects that data it would seem odd not to use it in any benchmarking metric on the settings suggestions.....
  • Hey people.

    I see everyone is **** at the game for not starting in full resolution.
    Game doesn't handle that part well, don't panic...fix is easy.
    It's basic stuff on any Windows...I guess you all know it but fail to remember it.

    Right click on your shortcut in desktop and choose as image shows.

    Titanfall_fix.jpg

    You are all welcome :)
    See you on battlefield.
  • I'd be more inclined to agree with you if this wasn't literally the only game I've ever had this problem with.

    But it worked, so I'm still going to say thank you.
  • zarkas6
    1 postsPosts: 1
    Same problem here.. often goes into window mode in the middle of a game, very annoying.
  • TrIpKeBAb
    7 postsPosts: 8
    Don't bother going into settings to set to full screen. Little trick that i learned back in the day when Quake 2 came out!

    Just hold down ALT+Enter and it will switch you to fill screen, wait till ur in main menu for it to work in TitanFall as even thats a little buggy during into screens.
  • zIBruhh
    1 postsPosts: 1
    edited April 2017
    well here is kind of a fix?
    http://imgur.com/a/tITsi
    Not only did it fix it, it also stayed in borderless mode. I like borderless window, because I alt tab a lot when I die or load.

    http://imgur.com/a/tITsi
  • Ceyly
    36 postsPosts: 39
    Borderless window isn´t really an option for me.. This issue has been arround since release, and it´s not even listed under "Known Issues".
    Darkzeta89 wrote: »
    This is yet another bug in the increasing list of annoyances in this game.

    THIS. Titanfall 2 is a great game, but the list of little annoying things gets longer and longer for me. Spawning right into enemy titan´s scopes 5 times in a row, then finally getting your own titan just to have the game crash right in the moment it lands... (error device hung.. another ignored bug alot of people have and doesn´t even appear on "known issues".) .. This is a tilter, im not alone with this i think. If i continue to play this will propably make me smash my table until it eventually breaks lol ...
  • Alphacopter
    12 postsPosts: 16
    Try this. Go here in File Explorer:

    %USERPROFILE%\Documents\Respawn\Titanfall2\local\videoconfig.txt

    Look for these two lines:
    "setting.fullscreen"
    "setting.nowindowborder"


    The fullscreen setting should be set to "1" and nowindowborder should be set to "0". If you still are experiencing issues, remove the following command line arguments and try again:

    -fullscreen
    -noborder
    -windowed
    -window


    In my case, "setting.fullscreen" and "setting.nowindowborder" were both set to "1", leading me to believe there might have been a conflict between the two, causing the game to launch in windowed mode.
  • donnysbeatz
    1 postsPosts: 1
    edited September 2017
    Don't want to revive and old thread but just wanted to add onto the solutions mentioned in this thread in case someone where to run into this issue in the future and Google.

    1. Navigate to the game install location
    2. Right-click on the Titanfall2.exe file and select "Properties"
    3. Select the "Compatibility" tab
    4. Ensure there is a check for the box with "Disable fullscreen optimizations"
    5. Click "Apply" then "OK"
    6. Start the game to verify working


    After doing this my game is able to run fullscreen without issue with Origin In-Game overlay.

    The ALT+ENTER combo did not work as it would look like it were going full screen but switch to windowed promptly after.
  • Revan7even
    1 postsPosts: 1
    edited August 20
    Both fixes have flaws unfortunately. You are honestly better off doing the Alt+Enter combo when the game launches.
    Try this. Go here in File Explorer:

    %USERPROFILE%\Documents\Respawn\Titanfall2\local\videoconfig.txt

    Look for these two lines:
    "setting.fullscreen"
    "setting.nowindowborder"


    The fullscreen setting should be set to "1" and nowindowborder should be set to "0"

    Can confirm that with the correct settings in the file, after the game launched it would launch in windowed mode, and re-opening the settings file showed both switch to 0, so using this method you have to set the file to read only, but it means you can't change settings. Additionally, it does not seem to work when first logging on to your PC, so it only takes effect after you launch Titanfall 2, close it, and restart it.
    Don't want to revive and old thread but just wanted to add onto the solutions mentioned in this thread in case someone where to run into this issue in the future and Google.

    1. Navigate to the game install location
    2. Right-click on the Titanfall2.exe file and select "Properties"
    3. Select the "Compatibility" tab
    4. Ensure there is a check for the box with "Disable fullscreen optimizations"
    5. Click "Apply" then "OK"
    6. Start the game to verify working

    After doing this my game is able to run fullscreen without issue with Origin In-Game overlay.

    The ALT+ENTER combo did not work as it would look like it were going full screen but switch to windowed promptly after.

    Can confirm that this prevent the game from changing the fullscreen setting back to 0 once you change the setting in game or the config file, but whenever you get an Origin notification it will switch to desktop while you're in the middle of a game.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!