Welcome to the Titanfall 2 Forums. We have made a few adjustments to help eliminate spam and fake accounts. Starting today to participate in discussions, you must own Titanfall 2 and have a linked EA account. If you're having issues posting but do own the game, log out completely and clear your browser cache, cookies, and temp files, then restart the browser.

Comments

  • i have the same problem. have tried most of the solutions posted and re installation of the redistributable. nothing works
  • i have the same problem
  • I am currently having he same problem. Tried the above solutions as well.
  • MechanicalElves
    1 postsPosts: 1
    edited November 2016
    Found the fix here you go
  • I have deinstalled all VC packages...then it worked. I think because of origin is trying to install x86 packages and its causing a conflict.
  • So i just bought this game, its been out for almost a month, why is this problem not fixed yet? Should i just get my money back since i bought something I can't play?
  • someone help! trying two days ago. I can not install. all installed
    error: the vc ++ redistributable runtime package was not installed SUCCESFULLY. Setup can not continue in 1601
  • Same problem here... call origin they tells me call microsoft. Microsoft tells me reset windows --' so does delete actual vc works and what did you do to fix it... my computer is just news from october lel and cant run titanfall 2 because a **** **** thing that is 2010 and 2012 version of vc++ --'
    I try all solution and when i try to search and repair vc++ it tell me allready got something running :-/
  • I have deinstalled all VC packages...then it worked. I think because of origin is trying to install x86 packages and its causing a conflict.

    Package on wondows or in _Installer -> vc -> reddit -> those files
  • hellfire71
    2 postsPosts: 2
    Just figured out EA probably won't refund me for their game that doesn't work. I've never had something quite like this happen when buying a game, I guess its a new age we live in.
  • bardoe
    1 postsPosts: 1
    edited December 2016
    I just purchased Titanfall 2 an hour ago and got that error.
  • I finally decided to buy this game because I got the first one and i love it and got this awesome deal for Chrismas my sons got me and this error come out...like seriously????? come on now.
  • Here a way to fix this:
  • jazzboxer
    1 postsPosts: 1
    Thank you for posting the videos on how to fix this, they pointed me in the right direction, the fix for me was to simply uninstall then reinstall the 2010 VC package like it said in the log file, the game is amazing well worth the trouble to fix, cheers.
  • IzakL
    1 postsPosts: 2
    I'm having this problem, but with the 2012 package. I can't even uninstall it.
  • dady0
    1 postsPosts: 1
    It is but now I cant play because I click and nothing.
  • ZakySlade
    1 postsPosts: 1
    hey hall,my download was stopped at 40%,the solution is easy,just remove all old version of Visual 2010,and then install again from the video tutorial of Theymoonwalf you can see where to go,i hope to help,now i m in game ,have a nice day to all*Metallico...
  • RUM1GZ
    1 postsPosts: 1
    edited January 2017
    Works Fine thank you man. You are the real MVP
  • I know its been a while since the last post here but I just got Titanfall 2 and same happened to me.
    Easy fix -

    1. Open regedit
    2. Search for Visual C++ 2010 & Delete every folder containing Visual c++ 2010 redistributable. (BE CAREFUL NOT TO DELETE ANYTHING ELSE)
    3. Make sure you delete every 2010 redistributable folder as said above.
    4. Go to your Titanfall Directory and manually install Visual c++ redistributable that comes with the install C:\Program Files (x86)\Origin Games\Titanfall2\__Installer\vc\vc2010sp1\redist or whatever drive you have Origin games installed on.
    5. Run and install the vcredist_x64.exe.
    6. Then select install Titanfall 2 as your normally would from Origin (Warning, origin may crash, restart and play)
    7. Play game

    I done this and it works perfect after only 1 try :)
  • Sethlty
    1 postsPosts: 1
    he dosen't work
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!