Welcome to the Titanfall 2 Forums. We have made a few adjustments to help eliminate spam and fake accounts. Starting today to participate in discussions, you must own Titanfall 2 and have a linked EA account. If you're having issues posting but do own the game, log out completely and clear your browser cache, cookies, and temp files, then restart the browser.

ERROR: Connection to Server timed out!

Comments

  • Xer0Signal
    13 postsPosts: 14
    Jacket785 wrote: »
    Xer0Signal wrote: »
    Has Respawn acknowledged this at all?

    Barely, The community manager wanted to see footage of this happening and I showed him along with a few others. However, we have not heard anything else from the CM or the staff at Respawn. I even tried tweeting them and no response.

    That sucks. You'd think they'd want to keep what fans they do have, happy.
  • udnSource
    1 postsPosts: 1
    I have same problem, hope fix this problem.
  • xCoky
    1 postsPosts: 1
    Interesting is i m having similiar problem but i m not getting connection timed out when loading but during matches, mostly near of of them. I m finding games easily and then all of sudden my ping jumps from 40 to like 2000 game lags to point i m not moving and after while i get connection timed out. after that i can easily jump back into multiplayer and play other match but its ruining game for me to a point when this happens 3 times in a row during match i just rage quite.

    no response from respawn and no fix since launch? not cool
  • Same for me on ps4. Either crashes at the jumping to location or after my first death. Game is litterally unplayable online
  • I'm having the same issue. Does anyone know the ports to use for port forwarding?

    I think the issue is on their end with not provisioning servers with high enough bandwidth. The issue was gone today when I tried playing at various times, but right around the late afternoon the lag came back as the servers filled up.
  • Jacket785
    157 postsPosts: 162 ✭✭
    Their latest update. Notice anything missing?

    Map Hack:
    Rebalanced Map Hack so that player locations will now pulse instead of always on. We'll continue to look into this boost and will modify it further if it continues to cause frustration.

    Titan Balancing:
    - Rebalanced Legion.
    - Rebalanced Tone.

    Due to player feedback we’ve tweaked the balancing on both of these Titans. We’ll continue to watch player feedback and address as needed.

    Pilot Changes:
    - Anti-Titan and Grenadier weapons once again restore ammo when embarking into your Titan.
    - Rebalanced Amped LMGs .


    Last Titan Standing:
    - Fixed an issue with bad start spawns on Exoplanet.
    - Fixed an issue that was causing round 1 to start while people were still connecting.

    Menus:
    - Fixed an issue with camos that would result in players not being able to clear the "NEW" message.

    Last but not least…You can now play Private Match Solo!
    "My expectations are usually low, so that I'm not disappointed"

  • I just tried port forwarding. Did not fix anything. I was disconnected from the server during my second match of the evening. Call of Duty: Infinite Warfare is sounding pretty good right about now...
  • Cobaaalt
    1 postsPosts: 1
    edited November 2016
    I have the same problem, but I found out it was related to the "loading time" itself, and not the ping, at least on my end.


    Platform: PC

    Summarize your bug : Server times out before I get past the loading screen.

    How often does the bug occur?
    Every time (100%) if loading a different map than the last one played
    Never (0%) if I get to play the same map twice in a row.

    Steps: How can we find the bug ourselves?
    Run Titanfall on a low-end pc, basically, try to get a 30 seconds loading.

    What happens when the bug occurs?
    I get the "Error, connection to server timed out"

    Data Center: Singapore 7ms

    Internet speed: http://www.speedtest.net/my-result/5773177421

    Details on what is happening:
    I think the game isn't waiting for me to load the game. I have a low end PC, and it takes me 30s to load a map. The time out threshold is probably set to something lower than this.
    The only way I get to play is to pick the same map twice in a row (if i'm lucky) so that the second time, it's still in memory and I can connect before the server is tired of waiting for me.

    Seriously, let the players load before kicking them out! (I play with low settings so I can't even reduce the quality to load faster.)
  • Assassio
    17 postsPosts: 19
    edited November 2016
    I just tried port forwarding. Did not fix anything. I was disconnected from the server during my second match of the evening. Call of Duty: Infinite Warfare is sounding pretty good right about now...

    Yeah impulsed bought Cod IW because TF2 is a broken mess. If it wasn't I wouldn't have.

    I bet when I get my Pro on the 10th it still won't be fixed.
  • campusteks
    2 postsPosts: 2
    I'm having the same issue on PC. Downloaded it via Origin........sucks though. We waited a long time for this to come out. I'm not feeling the gameplay in Multiplayer mode. Reminds me of Battlefield series.
  • stinchcom
    2 postsPosts: 2
    same here, on xb1, dropping connection, all other games fine, also, seems to happen late afternoon, early evening, played it this morning for 2 hours, no issues at all, ran like a dream. I love titanfall but unless this gets fixed soon i'll buy cod.
  • IronicCodeine
    10 postsPosts: 10
    edited November 2016
    I posted something similar over in the tf2 subreddit, but I'm having the same issue. Black loading screen with Jump noise before it freezes up.

    However, upon looking at my router's security log, I've noticed it says that I'm being UDP flooded, with all the packets coming from the same IP address. Looking around, this seems like a false flag that can show up in games that use a broad style P2P connection (CoD style multi-player as opposed to BF's server based) that causes some routers (Mine's a Belkin N600DB) to think they're being DoS'd and shut down the connection. Can anyone see if they are having the same event? Or even have the same router?
  • I've been having a server timeout message every time I go to customize a skin for anything. It doesn't matter if it's the Pilot or the Titan that is being customized. It lags for about 10 seconds and then takes me to the selection with a really laggy pace, often times with the selection jumping 2 instead of 1. And then it kicks me out. And this is done with the Xbox One.
  • I posted something similar over in the tf2 subreddit, but I'm having the same issue. Black loading screen with Jump noise before it freezes up.

    However, upon looking at my router's security log, I've noticed it says that I'm being UDP flooded, with all the packets coming from the same IP address. Looking around, this seems like a false flag that can show up in games that use a broad style P2P connection (CoD style multi-player as opposed to BF's server based) that causes some routers (Mine's a Belkin N600DB) to think they're being DoS'd and shut down the connection. Can anyone see if they are having the same event? Or even have the same router?

    I have the exact same router and am experiencing this. I tbink you might be on to sometging. Im going to try hardwiring straight from the modem and seing if this fixes anything
  • MARPATdroid
    1 postsPosts: 1
    edited November 2016
    I'm playing on PC, digital download. If they want video evidence that this is going on here is my *fun* gaming experience... I'll get 1 or 2 matches in and then this happens and it stays this way for like an hour. this hopefully they fix the stability issues. I mean right now as it stands the game only tells me servers in Europe and Asia are available, but I can still select NY or STL or someplace closer and usually connect, and play a few rounds even though they didn't respond to the pings. I'm gonna go mope. Since the formatting on this forum doesn't highlight links... every time you see the word "this" it is a hyper link. or you can just click here and it will take you to the video.
  • Update: it's still lagging severely for me and my friends, and we often get disconnected after a server timeout. Please fix your servers Respawn.
  • G_Moeen
    2 postsPosts: 2
    Ah, I'm getting the same problem as you guys. I thought I'd give this game a try, but so far it's been a waste of £55 :'(
  • Wilkostein
    4 postsPosts: 4
    Right mine is working fine now, no more server time outs after every match.
    I am on ps4 with plusnet. I changed my router from a technicolour 582n to a BT hub 6.

  • MESAjpn
    2 postsPosts: 2
    I have same problem.(PS4 & XB1)

  • Update: bypassed router and hardwires straight from modem and everything works fine. Appears to be a router issue. Look for my quoted post above for more context. Ill be trying another router to see if fixes remain
  • Jacket785
    157 postsPosts: 162 ✭✭
    Update: bypassed router and hardwires straight from modem and everything works fine. Appears to be a router issue. Look for my quoted post above for more context. Ill be trying another router to see if fixes remain

    I'll be giving it a shot this afternoon (or what little i'll have with it). I'm going to try wiring straight to the modem myself and see if that works.

    Also, I would seriously like to congratulate you and everyone else here. Unlike Respawn, at least we're actively looking into the problem and trying to get it fixed.
    "My expectations are usually low, so that I'm not disappointed"

  • IronicCodeine
    10 postsPosts: 10
    Looking at some of the older titanfall 1 issues, apparently they were having a similar issue back with people who had ADSL or Throttled connections, where the router would get overloaded during matchmaking and cause the game to hang and get kicked. So fingers crossed its not a complicated fix, just pulling back on how many ports the game asks for.
  • If we could get other peoples experiences if bypassing their router or replacing with a different type fixed these issues that would give us (the community) a solid direction on this problem i think. So if you are experiencing the jump to location freeze or other server connection timed out errors 100 perce t of the time try bypassong the router and letting us all know what happenes
  • Jacket785
    157 postsPosts: 162 ✭✭
    edited November 2016
    If we could get other peoples experiences if bypassing their router or replacing with a different type fixed these issues that would give us (the community) a solid direction on this problem i think. So if you are experiencing the jump to location freeze or other server connection timed out errors 100 perce t of the time try bypassong the router and letting us all know what happenes

    I've tried this but my ps4 didn't recognize it. However, my parents gave me one of their spare routers and I bought it back to my place. After restoring it to factory settings and going through configuration, I got it up and working. I tested it out with Titanfall 2 and I was able to play full matches. I kept this going and I haven't been disconnected at all! Now I can finally enjoy the game!

    If you're wondering what router i'm using now, it's a NETGEAR N900 Dual-Band Gigabit Router. My old router was a belkin router which I noticed a couple of other people have. The specific Belkin model I had was N450 DB Wireless Router. When I was using this I checked the security logs and noticed that it was also suffering from UDP flood which wound up causing DOS when trying to connect to games on Titanfall, yet strangely enough it doesn't have this issue when connecting in the middle of a match, but the effect will happen later after playing for 2-5 minutes.

    Possible Solutions:
    • Upgrade your router
    • Greatly limit the ports asked for
    • Add a "Throttled" network mode to the settings that lets you choose the one and only port the game will use.
    • Use your phone as a hotspot and connect to it using your PS4/XB1

    I will add more to this list once we figure out more solutions but this definitely worked for me. Let's keep on this guys! We can do it!
    "My expectations are usually low, so that I'm not disappointed"

  • oNeXuSo
    3 postsPosts: 3
    I'm finding Titanfall 2 on the XB1 plays without any issues during the morning / early afternoon. I'll get the jump to location freeze 100% (which is annoying!) from around 7 pm UK time until the following day. It'll work again until that evening and so on. Game has had this same issue since release date. Other games are working as expected. Has anyone official to the game provided any updates on this other than being noted halfway down a known issues thread?
  • Just a note: after hardwiring directly from the modem to the ps4 reset the modem (just unplug it for 10 seconds) before setting up the wired connection. The modem needs a reset before the ps4 (or any device) will recognize it. Figure uf post this as most of us will be trying this as a test
  • Having the same issue here in the U.K. on PS4. I get booted out at 'jumping to location' sometimes I appear on the ground unable to move.

    I'm hoping this is going to get sorted soon because it's frustrating not being able to access a major component of the game.
  • Assassio
    17 postsPosts: 19
    edited November 2016
    I'm not buying a new top notch expensive modem to fix what is an Respawn problem. All my other games work but this one, I'm disabled and not made of money.

    The one I have now wasn't cheap, it's a proper gaming one. Taking the risk in buying a new one in the vague hopes it MIGHT fix it is ****.

    Screw that.

    Yes I'm frustrated lol, rant at Respawn over.
  • IronicCodeine
    10 postsPosts: 10
    edited November 2016
    Checking back in.
    Set up a Hotspot on my phone, and what would you know, it runs smooth as butter. Finished up, reconnected to my router, and not 3 minutes into a match I get kicked back to the main menu, and was unable to join after that.

    Checking the logs, it's another UDP flood.

    Just a note for some people : a new modem wouldn't help, as it's a router issue, and a fairly simple one to take care if Belkin wasn't trying to play safe with your connection. Unfortunately you can't override that particular safety setting, at least one on my model, so there's no client side way to fix it.

    Possible fixes? Easy. Double checking all the logs I've saved, it seems Respawn is using almost every port from 100 - 40000. Probably a coder shortcut to allow better peer to peer connections, but it also means that it's flooding the router when it sends all those out at one time. An easyish solution would be to either A ) greatly limit the ports asked for or B ) add a "Throttled" network mode to the settings that lets you choose the one and only port the game will use. I know Warframe does something like that, but I have no idea how easy it is to implement
    .
  • killinV
    11 postsPosts: 12
    Checking back in.
    Set up a Hotspot on my phone, and what would you know, it runs smooth as butter. Finished up, reconnected to my router, and not 3 minutes into a match I get kicked back to the main menu, and was unable to join after that.

    Checking the logs, it's another UDP flood.

    Just a note for some people : a new modem wouldn't help, as it's a router issue, and a fairly simple one to take care if Belkin wasn't trying to play safe with your connection. Unfortunately you can't override that particular safety setting, at least one on my model, so there's no client side way to fix it.

    Possible fixes? Easy. Double checking all the logs I've saved, it seems Respawn is using almost every port from 100 - 40000. Probably a coder shortcut to allow better peer to peer connections, but it also means that it's flooding the router when it sends all those out at one time. An easyish solution would be to either A ) greatly limit the ports asked for or B ) add a "Throttled" network mode to the settings that lets you choose the one and only port the game will use. I know Warframe does something like that, but I have no idea how easy it is to implement
    .

    If the problem is the router getting flooded by UDP packets, wouldn't a direct conection from Modem to PC/XBX1/PS4 work?? I mean, I know is not a solution, but did you tried this?

    I'm not having OP's problem, what I have is out of nowere LAG, DataCenter says 40ms but when I join a game I get 180-250+ms. Using a VPN at the moment and that seems to fix it, but I'm using some Trial VPN software and I'm not willing to pay to play the game without lag because every other game I play doesn't have this problem.

    The annoying part of all of this is Respawn not even saying "Hey guys, we are aware of this issue and we have people working on this" and this is not even on the "Known Issues" list, so, What the **** is goin' on?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!