Welcome to the Titanfall 2 Forums. We have made a few adjustments to help eliminate spam and fake accounts. Starting today to participate in discussions, you must own Titanfall 2 and have a linked EA account. If you're having issues posting but do own the game, log out completely and clear your browser cache, cookies, and temp files, then restart the browser.

Audio Crackling and Popping

Comments

  • KDeimos89
    21 postsPosts: 22
    edited December 2016
    I got the same problem. I really forgot to mention that, i was focused on the micro stuttering issue. After a certain time in a match, some sound effects are getting like "chopped" off or make more or less just a "pop" sound. It's like there are too many effects at the same time. Best example is in Attrition mode with all it's AI, Titans and pilots.
    It's the only game which does that. Planetside 2 for instance works fine with it's maximum 192 sound channels.

    My system again:
    Windows 10
    i5 6600
    24GB RAM HyperX Fury 2133
    XFX RX 480 GTR
    Asus Xonar D1
    Samsung 850 Evo
    Crucial M500


  • AKManiac420
    1 postsPosts: 1
    edited December 2016
    I have the same issue when im ingame and titans start to drop and battle, i get the crackling sound.

    My System:

    AMD FX(tm)-6300

    8192MB RAM

    NVIDIA GeForce GTX 960

    Windows 10










  • I have the same issue. The audio begins to crackle and pop and then my frame rate will drop to the point where i can't even aim properly anymore because of the input lag. I Have even set the game's priority setting in the task manager to real-time and i lowered my audio quality to 24-bit 48000 Hz. I also created a desktop shortcut and launch the game through that. The problem continues to persist. I haven't disabled Origin In-game only because I play with friends and need to invite them through it, but I doubt that will make a significant difference. All my other games don't have any issues with the sound. In fact Tom Clancy's Rainbow Six Siege requires to me to change my audio quality back to 24-bit 192000 Hz in order to play it.
    My Specs:
    AMD FX-4350 Quad Core
    8GB RAM
    R9 290X
    Windows 10
    Razer Kraken Headset (non USB)

    Any help would be greatly appreciated because this game is barely playable in its current state.
  • Still waiting on a fix for this....
  • MASTERX1234
    68 postsPosts: 77
    If anyone finds a temporary fix, it would be greatly appreciated, i experience this bug on only 2 maps and the rest are fine, mine isnt as bad as the reports ive seen before but it is very annoying. Ive set the audio quality to the lowest Hz rate and everything.
  • Still having this problem myself. I would love a fix. This thread was started in October.
  • this is becoming a **** show,isnt the reason for forums based on isses so they can be heard and fixed if not fixed then at least tell us your listening
  • Exact same issue. Like 36_Bit_Gaming said, this isn't an official bug report forum, it's just a brick wall EA provides to be shouted at.
  • parkbot
    9 postsPosts: 9
    Some of you may be interested in this post:
    https://www.reddit.com/r/titanfall/comments/5goz53/these_3_things_are_the_cause_of_stutter_on_pc/

    I tried them and it didn't help me, but it might help some of you.
  • icemount
    2 postsPosts: 2
    Guys try disabling Origin overlay.
    Next to Play button in Origin, settings -> game properties-> untick "Enable Origin Overlay"
  • I having this issue but on xbox 1
  • Lukozade95
    1 postsPosts: 1
    Alright, I've been following this for a while and I think I've fixed the issue. I'm pretty confident its a CPU issue, as most people I see posting about this are using older or weaker CPUs like I am (for now!), like AMD A10 and Core i3s etc.

    So, reading what some other people said, I shut down Discord, Steam, and Origin In Game Overlay. I also set the CPU priority for Titanfall2.exe to 'High'.

    I haven't had time to see which one of these specifically fixed the issue, but all I can say is that it's gone from utterly unplayable and laggy to smooth FPS and perfect audio.

    Hope this helps someone!
  • Clean installed Win 7 64 bit & Titanfall 2 3 times ALREADY , garbled sound STARTS AFTER 1 mp SESSION ALL THE TIME
    WHEN ARE YOU GONNA TAKE US SERIOUS ? iT'S KILLING THE GAME!
  • tyrusdixon
    1 postsPosts: 1
    My problem is in the same boat. This was not a problem at all for me when I played around release. Just started playing again after the Angel City update. Now after about 30 min of gameplay (online or off) I start to hear the telltale crackling in my speakers, then every time an intense fight shows up I get severe framerate drops. I believe this may be a problem with the garbage collection or something. IDK I'm not a coder. Here is my build info

    PC IBuyPower
    Windows 10 Pro Version 1607 OS Build 14393.447
    Processor: AMD FX(tm)-8350 Eight-Core Processor 4.00 GHz
    Installed Ram 16.0 GB
    64-bit operating system x64 based processor
    Video Card: 1 x AMD Radeon R9 280 - 3GB - Single Card
    The game loads from my 2nd drive, HDD
    I play on a 55 inch TV screen HDMI linked
    Audio goes through 3.5mm jack to my stereo speakers
    My internet is speed tested to 250 mbps through comcast

    This is not a problem with any recent title (BF1, Civilization)
  • KDeimos89 wrote: »
    I got the same problem. I really forgot to mention that, i was focused on the micro stuttering issue. After a certain time in a match, some sound effects are getting like "chopped" off or make more or less just a "pop" sound. It's like there are too many effects at the same time. Best example is in Attrition mode with all it's AI, Titans and pilots.
    It's the only game which does that. Planetside 2 for instance works fine with it's maximum 192 sound channels.

    Hi all,

    After 3 clean installs of Win 7 64 bit & downloading all the GB of TF 2 again i'd the 'garbled sound' again straight from the start.
    I'm using Razor Kraken 7.1 as a headset.

    I found out that the Razor synapse software installs Framework 4, but does NOT install the latest version.
    After checking with MS it appeared NOT to be the latest version of the framework, that will be :
    MS Framework 4.6.2

    I've installed this latest version and my audio is A-OK !!!!
    Not to say it will solve it for everyone, but, it did 4 me ....
    download link : https://www.microsoft.com/en-us/download/details.aspx?id=53344

    Happy hunting !
  • MASTERX1234
    68 postsPosts: 77
    KDeimos89 wrote: »
    I got the same problem. I really forgot to mention that, i was focused on the micro stuttering issue. After a certain time in a match, some sound effects are getting like "chopped" off or make more or less just a "pop" sound. It's like there are too many effects at the same time. Best example is in Attrition mode with all it's AI, Titans and pilots.
    It's the only game which does that. Planetside 2 for instance works fine with it's maximum 192 sound channels.

    Hi all,

    After 3 clean installs of Win 7 64 bit & downloading all the GB of TF 2 again i'd the 'garbled sound' again straight from the start.
    I'm using Razor Kraken 7.1 as a headset.

    I found out that the Razor synapse software installs Framework 4, but does NOT install the latest version.
    After checking with MS it appeared NOT to be the latest version of the framework, that will be :
    MS Framework 4.6.2

    I've installed this latest version and my audio is A-OK !!!!
    Not to say it will solve it for everyone, but, it did 4 me ....
    download link : https://www.microsoft.com/en-us/download/details.aspx?id=53344

    Happy hunting !

    Doesnt really help us on Windows 10 because NET Frameworks 4.6.2 is built into the operating system. If i attempt to install 4.6.2 it just says its already installed. I fixed at least 99% of my static and hissing by changing the audio to 16-bit and updating my sound drivers to the latest.
  • KDeimos89 wrote: »
    I got the same problem. I really forgot to mention that, i was focused on the micro stuttering issue. After a certain time in a match, some sound effects are getting like "chopped" off or make more or less just a "pop" sound. It's like there are too many effects at the same time. Best example is in Attrition mode with all it's AI, Titans and pilots.
    It's the only game which does that. Planetside 2 for instance works fine with it's maximum 192 sound channels.

    Hi all,

    After 3 clean installs of Win 7 64 bit & downloading all the GB of TF 2 again i'd the 'garbled sound' again straight from the start.
    I'm using Razor Kraken 7.1 as a headset.

    I found out that the Razor synapse software installs Framework 4, but does NOT install the latest version.
    After checking with MS it appeared NOT to be the latest version of the framework, that will be :
    MS Framework 4.6.2

    I've installed this latest version and my audio is A-OK !!!!
    Not to say it will solve it for everyone, but, it did 4 me ....
    download link : https://www.microsoft.com/en-us/download/details.aspx?id=53344

    Happy hunting !

    Update : after 1 h of play, garbled sound again .... OMG, i'm getting ready to never see this game again...

  • the crackling has only just started happening for me -_- so annoyed
  • krazyyon
    2 postsPosts: 2
    Titanfall 2 - Pc

    Specs: Win 7
    AsRock H87 Pro
    i5 4670
    GTX 970 MSI
    8 Gig DDR 3 RAM Corsair

    Medusa 7.1 XE

    Hey there,

    i play tf2 for six weeks now and the first couple of weeks it ran smooth and i was happy about that, cause tf1 has some really annoying mouse issues. however, for a while now i have the same problem like all of us (lag spikes, sound bugs, crackling, stuttering even without any fps loss etc) and short after i noticed it, i searched for a solution.

    soon i was sure, there is no solution yet, after reading and reading and surfing thru the forums. not just the titanfall forums.
    ive tried everything what came in my mind, the different settings ingame, nvidia experience (max performance) etc etc, the known stuff.
    ive tried the one with the settings.cfg (gpu_vram_size_mb "XXXX") the x is ur vram memory - but even this seems not to be working.

    long story short - i have enabled vsync, first in the game (triple buffered) with following but not that annoying delay and after that ive enabled vsync thru nvidia experience - which also causes a lil bit of a delay, but its almost fine.

    but it wasn't enough for me, so i just closed nvidia experience itself.... cause i was out of ideas and there u go. the game runs smooth as butter, even without any vsync.

    no lag spikes, no sound crackling/stuttering, nothing! ...atleast for now...

    often i read this is caused by the 7.1/5.1 headsets, but can't test it yet with any other headset cause my old one (just stereo) is broken.

    alright, hope it helps some of u and sry for the boring text. im tired af, but after all this research and desperation i want to let u know that there is a solution... maybe.

    TITANLOVE
  • h4r0n144
    1 postsPosts: 1
    Same here, lol.

    MSI Ge-Force 1050 Ti 4 GB
    I5-2500 3,3
    12 GB ram
    win10
    roland quad capture 2 audio interface

    **** ;/
  • Lukozade95 wrote: »
    Alright, I've been following this for a while and I think I've fixed the issue. I'm pretty confident its a CPU issue, as most people I see posting about this are using older or weaker CPUs like I am (for now!), like AMD A10 and Core i3s etc.

    So, reading what some other people said, I shut down Discord, Steam, and Origin In Game Overlay. I also set the CPU priority for Titanfall2.exe to 'High'.

    I haven't had time to see which one of these specifically fixed the issue, but all I can say is that it's gone from utterly unplayable and laggy to smooth FPS and perfect audio.

    Hope this helps someone!

    I've confirmed this to be a possible fix for folks. I have an AMD Phenom II X4 975, which is probably six years old. Changing the game's priority (in W10 from normal to High) seems to have fixed the issue for me.
  • +1. I know TF2 is the culprit 'cos all my other games run perfectly, sound and otherwise. I'm finding it varies from almost none, to enough to make the game unplayable, at least for a few seconds. It sort of 'half-crashed' the game once too. A fix would be very nice, please.
  • ghostsquad2020
    4 postsPosts: 4
    edited December 2016
    Loopsample wrote: »
    +1. I know TF2 is the culprit 'cos all my other games run perfectly, sound and otherwise. I'm finding it varies from almost none, to enough to make the game unplayable, at least for a few seconds. It sort of 'half-crashed' the game once too. A fix would be very nice, please.

    Have you tried changing the game priority to High? Literally, the problem is that the game is poorly designed for older hardware. I've played 24 games since knowing of this fix with 0 problems. You'll need something like system explorer in order to have the priority always be set to High everytime you open the game.

    http://www.ilovefreesoftware.com/27/windows-10/permanently-set-priority-level-process-windows-10.html
  • I'm getting this problem too.



    *The game starts off sounding great then the problem pops up after 20-40mins of playtime.
    *I usually play using dolby headphone or Dolby digital Live through a Xonar DX.
    *no problems with any other games or music applications etc.

    I heard 1 pop so loud today that I am actually worried this may damage my headphones.
    This really needs to be sorted.

    System specs:

    cpu: Intel i7 6700k
    mobo: Asus Maximus VIII Hero
    ram: Kingston HyperX Fury 16GB (2x8) DDR4 2400Mhz
    gpu: EVGA GTX 1080 FTW
    psu: Seasonic Platnium 80+ 760w
    ssd: OCZ vertex 4 (256GB)
    Monitor: Acer Predator XB270HU
    Sound Card: Xonar DX
  • I'm getting this problem too.



    *The game starts off sounding great then the problem pops up after 20-40mins of playtime.
    *I usually play using dolby headphone or Dolby digital Live through a Xonar DX.
    *no problems with any other games or music applications etc.

    I heard 1 pop so loud today that I am actually worried this may damage my headphones.
    This really needs to be sorted.

    System specs:

    cpu: Intel i7 6700k
    mobo: Asus Maximus VIII Hero
    ram: Kingston HyperX Fury 16GB (2x8) DDR4 2400Mhz
    gpu: EVGA GTX 1080 FTW
    psu: Seasonic Platnium 80+ 760w
    ssd: OCZ vertex 4 (256GB)
    Monitor: Acer Predator XB270HU
    Sound Card: Xonar DX

    Did you try setting the game process priority to high? Did you read the rest of the thread before posting?
  • Battlefield 1, CS;GO, WoW, Overwatch, BF4, BFH, and countless other games. I get no audio issues. I even push my stuff hard, but this is the only game it makes it nearly unplayable due to the constant sound issue!!!!!!
  • Have had the game for 72 hours now and here i go.... crackle and pop from day 1. Not the greatest rig but it runs everything else with no issues.
    FX4100 quad core @ 3.6 ghz
    8 gb ram
    nvidia 960
    blah blah blah
    doesn't seem to be a concern at all. Dont see any admins or response or acknowledgement just some **** about "sometimes acts odd during voice chat."
    I'm ****. to find this long thread existed the whole time I'm convincing my friends to buy this.... I look like a complete asshat now.
  • can confirm, setting to high priority fixed the issue. I have a X4 760k @ 4.4 Ghz.
  • KDeimos89
    21 postsPosts: 22
    can confirm, setting to high priority fixed the issue. I have a X4 760k @ 4.4 Ghz.

    I also tried it, still the same issue for me.
    Anyway, merry christmas.
  • Today I swapped out my old CPU-Cooler and cleaned my PC a bit. It fixed my problem. I think the CPU was getting to hot. Try it if you have the chance ;)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!