Welcome to the Titanfall 2 Forums. We have made a few adjustments to help eliminate spam and fake accounts. Starting today to participate in discussions, you must own Titanfall 2 and have a linked EA account. If you're having issues posting but do own the game, log out completely and clear your browser cache, cookies, and temp files, then restart the browser.

After opening the game the screen become black and cannot enter

Haganbana
0 postsPosts: 1
But my computer has already fulfiiled the recommed enquiries

Comments

  • Sledge70
    148 postsPosts: 227 Community Manager
    Can you provide your system specs?
    Thanks
    Sledgehammer70
    Sledgehammer70
  • OlivorKlozov
    1 postsPosts: 1
    edited October 2016
    Seeing the same issue here. I can start the game but when trying to join a multiplayer lobby (not even a game) the screen goes black (no signal) and I need to hard restart the computer. I checked the event viewer for any system errors and aside from the "previous shutdown was unexpected" there are no errors indicating what happened.

    Last night I was able to play the game for a few hours without any issues (with the first wave of AMD driver patches for TF2), but today since installing the newest AMD drivers released this morning it keeps crashing. Since last night Windows also applied a few updates, so that might be related.

    OS: Windows 10 Professional 64 bit - Version 10.0.14393 Build 14393
    CPU: AMD FX9590
    Mobo: Gigabyte 990FXA-UD3 R5 (F3 bios)
    Memory: 16 GB DDR3-1600
    GPU: AMD R9 280X
    Monitor: ASUS MG248Q (1080x1920 @144Hz)

    Video settings are as low as they can go in every category.

    GPU Drivers info:
    Driver Packaging Version: 16.40.2911.1001-161025a-308178E
    2D Driver Version: 8.1.1.1571
    Direct3D Version: 9.14.10.01221
    OpenGL Version: 6.14.10.13456
    OpenCL Version: 21.19.155.257
    AMD Mantle Version: 9.1.10.0163

    Edit: Just verified this also happens when trying to start the campaign.

    Edit 2: Tried rolling back AMD drivers, no luck.

    Edit 3: Tried uninstalling and reinstalling, no luck. Thought it might be a hardware issue so I took apart everything and dusted/cleaned, still no luck.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!